[Suzaku-en:00878] Re: running your own app from flash

Andries Muis - LR email@hidden
Thu Jan 6 21:52:38 JST 2011


Hi everyone,

 

Could anybody give me a solution for this problem? I thought it wasn't a
big problem but I don't see the solution. What I want is:

 

Bboot starts hermit. Hermit should copy my application from flash to
ddr. And then do a software reset so my program starts. Could anybody
explain how I should create the second application in EDK (linker
scripts, memory). Just a simple xil_printf command in the second
application is ok. I'm using the default project from atmark for my
sz410 edk 11.5

 

Thanks.

 

Andries

 

________________________________

From: email@hidden
[mailto:email@hidden] On Behalf Of Andries
Muis - LR
Sent: woensdag 22 december 2010 11:18
To: email@hidden
Subject: [Suzaku-en:00877] running your own app from flash

 

Hi all,

 

I'm still trying to run my program from flash. This is what I did. I
created a second software project in Xilinx EDK. Linker file looks
towards the bram sections for all .text etc. Then I set the start
address to 0xffffc000. After that I converted the .elf file to .bin file
with powerpc-eabi-objcopy -O binary exe.elf flash.bin. 

Then I tried to approaches. One I created an complete .mcs file which
contains the default fpga.bit, the bootloader.bin file and my own
created flash.bin. By using direct spi I uploaded this into my flash.
After reboot it shows me "copying kernel ....... Done. Nothing more. I
think this line comes from the default boot sequence from hermit
bootloader. I also can use the JP1 to activate hermit. But my program
doesn't start. Then I tried using hermit by uploading my flash.bin into
the kernel region and the image region. Again no changes. 

 

Can anyone explain me how to copy my program into flash run it without
using the linux kernel.

 

Thanks,

 

Andries

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.atmark-techno.com/pipermail/suzaku-en/attachments/20110106/c2c9aa09/attachment.html>


More information about the suzaku-en mailing list