[Armadillo:00189] HELP!!!!!...(it is very urgent, we can not download our application and new kernel setting use your code, and it is not match your user manual)

研三部_楊禮謙 email@hidden
2005年 3月 23日 (水) 23:48:40 JST

Dear Fumito san:

     We try new version base.img(ver 1.11),and it is OK

     But we can not download new setting of kernel and application with your source according you usr mamual


     About new question

1.        we have tried recover-2.08.img with discover.exe,it is still not OK

2.        we have change our web to vendors/AtmarkTechno/Armadillo-J.Base/home/www directory

and then do make romfs command, it will create romfs.img,and then do ./hermit download –i romfs.img –r user

and then and open JP4,and then restart target system,We can not see any action on hyperterminal

and if we close JP4,we can see some action on hyperterminal.just like that



and then we key in


we can see kernel action only,and run “kernel done…….”only

and then system do nothing,(system does not go to login step)


According to user menu. we can not understand the right procedure.

Please tell us the correct procedure how we can download our application to target board

Because we can not build our application with your user menu.


3.        could you tell what’s mean of linux.bin:

because we do make menuconfig to config our setting,and then do make dep

,and do make,system only create image.bin and romfs.img,image.bin.CHKSUM

,but we do not see the file linux.bin,could you tell me what linux.bin is


And we download image.bin to target board with firmupdate command,

System do nothing,only show message “bin too small”


4.  if we change kernel’s setting with make menuconfig,please tell us how to do

We can download new image file to target board.(according to user manu,it is not ok)

(the version that we use is(arm-elf-tools-20030314.sh <http://armadillo.atmark-techno.com/download/armadillo-j/cross-dev/arm-elf-tools-20030314.sh>   )and uclinux (uClinux-dist-aj20050105.tar.gz <http://armadillo.atmark-techno.com/download/armadillo-j/dist/uClinux-dist-aj20050105.tar.gz> )

They are all download from your web


Please tell us,it is very urgent., thank you




                                             Angus mail from EMINE

Your problems seem me that network doesn't work as same as when you used the old "base.img".


Could you download the newest version of recover.img and try it ?

It can be downloaded from:

http://download.atmark-techno.com/armadillo-j/image/recover-2.08.img <http://download.atmark-techno.com/armadillo-j/image/recover-2.08.img> 


About new questions.

1. The "recover.img" doesn't include boot loader but kernel and user land.

2. In the uClinux-dist source tree, there is index.html file under vendors/AtmarkTechno/Armadillo-J.Base/home/www directory.

Please change this file as you like and then compile.

You could know how it works seeing





-------------- next part --------------
URL: <http://lists.atmark-techno.com/pipermail/armadillo/attachments/20050323/7b241a26/attachment.html>

armadillo メーリングリストの案内