[Armadillo:08716] Any tools for diagnosing bricked Armadillo 420

Brian Estey email@hidden
2013年 4月 2日 (火) 10:53:10 JST

Hello all,

I wrote last week about the board I'm working with and unfortunately I 
think I may not have responded correctly and my message got lost(?).  Or 
perhaps there's no hope for me.  I'm hoping it's the former =)

I tried to flash a boot.bin file that is supplied in the BSP 
(wec7-on-armadillo440_20120529) but it failed to restart after the 
flashing was complete.

I've tried putting the jumper back on JP1 and this lights up LED5 but I 
don't seem to get anything on the serial console.

As suggested previously, the boot.bin I flashed is ~30MB which seems to 
exceed the 16MB NOR and this could be the reason it doesn't boot.  My 
question here is would this cause the entire board to not even start or 
should I see something on the serial console?

Also, it was suggested to try to reflash the bootloader with Hermit-At, 
but doing this resulted in an error window with the title "shoehorn" and 
truncated text:

libs/shoehorn-armadillo4x0.bin: 1272 bytes (2048 byt
libs/loader-armadillo4x0-boot.bin: 49144 bytes (4914
Access is denied.

And another dialog with the title "callback" that simply says "Access is 
denied" with only one button "OK".

Any advice on what to do or where to look would be appreciated.


armadillo メーリングリストの案内